Raspberry PiでSkype・TS3・Dropbox等を使う方法

IoT
スポンサーリンク

先日入手したRaspberry Pi 3(以下ラズパイ)を緊急用のサブマシンに仕立てるべく、Skypeをインストールしようと調べたところ、通常はインストールしてもエラーが出て使用することができないようです。TS3サーバーやDropboxなども同様です。

ラズパイのCPUはARMですが、Skypeなどで対応しているのはインテルやAMDのx86系CPUなので、この違いでエラーが出るようです。

さらに調べるうちに、検索にヒットした英語のページで方法を見つけたので紹介します。

スポンサーリンク

ExaGear Desktopをインストールすればいける!

結論から言うと、下のページの”ExaGear Desktop”をインストールすると、SkypeやTS3サーバー、Dropboxなどが使えるようになります。

https://eltechs.com/product/exagear-desktop/

ページ冒頭の紹介文を適当に訳してみました。

Eltechs ExaGear Desktopはインテルx86CPUのアプリケーションと通常のネイティブアプリケーションをARMベースのミニPCで同時に実行することができます。ExaGear Desktopは仮想x86Linuxコンテナを実装し、ARM上で直接x86アプリケーション実行することを許可する仮想マシンです。QEMUに似ていますが5倍速い!WineをインストールすればWindowsアプリケーションも実行できます。

要するに、「ラズパイ(ARMミニPC)でx86CPUのLinuxアプリが使える仮想マシン」ということです。Wine(Linux上でWindowsアプリを使えるようにするソフト)も使えるのはすごいですね。

気になるお値段ですが、ラズパイZERO用・ラズパイ1用が16.45ドルで、ラズパイ2用・ラズパイ3用が27.45ドルです。

https://eltechs.com/product/exagear-desktop/exagear-desktop-features-and-prices/

アプリ別インストール方法

Skypeのインストールは下のページを参照して、”Skype installation instruction”以下の四角で囲まれたコードを上から順番に実行していけばOKです。サウンド関連のPulse Audioからなので、初心者の方でも大丈夫だと思います。

https://eltechs.com/run-skype-on-raspberry-pi/

TS3サーバーやDropboxのインストール方法もあります。

https://eltechs.com/run-teamspeak-3-server-on-raspberry-pi/
https://eltechs.com/run-dropbox-on-raspberry-pi/

他にも「ラズパイ アプリ名」で検索するとヒットしますので、探してみてください。

まとめ

ExaGear Desktopという仮想マシンをインストールするだけで、本来動かないはずのx86CPUのアプリケーションを動かせるのは素晴らしいですね。ラズパイ2or3をPCとして使用したい方は要チェックだと思います。ラズパイ2だとオーバークロックしないといけないところがネックでしょうか。

余談ですが、Android端末(ARM)にUbuntuをインストールして使い倒すような変態的なことができそうなので、夢が拡がります。

個人的にはSkypeを使えると非常時に助かるので、3000円弱ならば購入もアリだと思っています。入手したらまたレポートしますね。

コメント

  1. 高橋 昇 より:

    RaspiでSkypeが使えるという記事を拝見してexagearを購入してみました。

    RaspberyPi3 B+ に
    Raspbian Stretch with desktop and recommended software
    Version: November 2018 Release date: 2018-11-13
    をいれて すべて指定通りに作業を進めましたが
    pi@raspberrypi:~/Downloads $ sudo dpkg -i skype-debian_4.3.0.37-1_i386.deb; sudo apt-get install -f

    Package libqt4-dbus is not installed.
    Package libssl1.0.0 is not installed.

    dpkg: error processing package skype (–install):
    dependency problems – leaving unconfigured
    Processing triggers for dbus (1.10.26-0+deb9u1) …
    Errors were encountered while processing:
    で失敗します。 exagearはwineのインストールはできているので
    SKYPEの問題と思います。
    実際に動作させられた、各種要素の組み合わせを教えて頂ければ幸いです。

    • Akihiro Mori より:

      ExaGearを購入なさったのですね。
      申し訳ありませんが私は購入していませんので詳細はわかりませんが、「パッケージがインストールされていない」というエラーのようなので、下記でパッケージをインストールしてみてはいかがでしょうか。

      sudo apt-get libqt4-dbus
      sudo apt-get libssl1.0.0

      うまくいったらご報告頂けると嬉しく思います。

トップへ戻る
タイトルとURLをコピーしました